Working with Varying Vagrant Vagrants today and having problems spinning up a new box? Don’t blame yourself. It appears that the PHP 7.2 libs… in fact ALL of the PHP libs for Ubuntu Trusty have gone away.

The ppa:ondrej/php repository that is cited everywhere has decided it is not going to serve up any PHP code to your Vagrant boxes today.

Maybe they’ll fix it soon. Maybe not. If anyone has a workaround please comment here.

vagrant up technicolor yawn…

default: Installing apt-get packages...
    default: Reading package lists...
    default: Building dependency tree...
    default: Reading state information...
    default: E
    default: : 
    default: Unable to locate package php7.2-fpm
    default: E
    default: : 
    default: Couldn't find any package by regex 'php7.2-fpm'
    default: E
    default: : 
    default: Unable to locate package php7.2-cli
    default: E
    default: : 
    default: Couldn't find any package by regex 'php7.2-cli'
    default: E
    default: : 
    default: Unable to locate package php7.2-common
    default: E
    default: : 
    default: Couldn't find any package by regex 'php7.2-common'
    default: E
    default: : 
    default: Unable to locate package php7.2-dev
    default: E
    default: : 
    default: Couldn't find any package by regex 'php7.2-dev'
    default: E
    default: : Unable to locate package php-imagick
    default: E: Unable to locate package php-memcache
    default: E: Unable to locate package php-memcached
    default: E: Unable to locate package php-ssh2
    default: E: Unable to locate package php-xdebug
    default: E: Unable to locate package php7.2-bcmath
    default: E: Couldn't find any package by regex 'php7.2-bcmath'
    default: E: Unable to locate package php7.2-curl
    default: E: Couldn't find any package by regex 'php7.2-curl'
    default: E: Unable to locate package php7.2-gd
    default: E: Couldn't find any package by regex 'php7.2-gd'
    default: E: Unable to locate package php7.2-mbstring
    default: E: Couldn't find any package by regex 'php7.2-mbstring'
    default: E: Unable to locate package php7.2-mysql
    default: E: Couldn't find any package by regex 'php7.2-mysql'
    default: E: Unable to locate package php7.2-imap
    default: E: Couldn't find any package by regex 'php7.2-imap'
    default: E: Unable to locate package php7.2-json
    default: E: Couldn't find any package by regex 'php7.2-json'
    default: E: Unable to locate package php7.2-soap
    default: E: Couldn't find any package by regex 'php7.2-soap'
    default: E: Unable to locate package php7.2-xml
    default: E: Couldn't find any package by regex 'php7.2-xml'
    default: E: Unable to locate package php7.2-zip
    default: E: Couldn't find any package by regex 'php7.2-zip'
    default: Main packages check and install failed, halting provision
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

A manual hack attempt – fail

# vagrant ssh
># sudo apt-get install software-properties-common
># sudo add-apt-repository ppa:ondrej/php
># sudo apt-get update
># sudo apt-get install -y php7.2

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package php7.2
E: Couldn't find any package by regex 'php7.2'

2 Comments on “Ubuntu Trusty: PHP 7.2 MIA

    • Also issues on 16 and 18.

      Ubuntu PHP world is in disarray at the moment.

      The latest develop version of VVV points to a new custom box image of Ubuntu with the PHP environment rebuilt.

Share Your Insight

%d bloggers like this: